S3Bubble OTT Streaming

shape
shape
shape
shape
shape
shape
shape
shape

S3Bubble Support Forums

To stay up to date with the latest S3Bubble updates and tutorials please make sure you sign up to our YouTube Channel.

home Forums General Questions & Bugs Video buffering lagging & quality

Viewing 2 reply threads
  • Author
    Posts
    • #31924
      szmek9
      Participant

      Some users are having problems with video buffering. They saying that video loads up to some point and than stops… they try to refresh the page but problem persists.

      I use all default presets, I tried even to encode video before uploading it with Handbreak you recommend.

      I have such warning after encoding my videos, but I was ignoring it… (I am creating videos using Camtasia Studio Software)

      SOME INDIVIDUAL SEGMENT FILES FOR THIS OUTPUT HAVE A HIGHER BIT RATE THAN THE AVERAGE BIT RATE OF THE TRANSCODED MEDIA. PLAYLISTS INCLUDING THIS OUTPUT WILL RECORD A HIGHER BIT RATE THAN THE RATE SPECIFIED BY THE PRESET.

      I host 90% videos using Virginia Server with cloudfront… So my guessing was that maybe localization is causing the problem, so I hosted videos in Ireland for testing, however encoded videos with Cloudfront don’t seem to play (don’t know if it is separate issue, or is it not possible to have video in EU Ireland with cloudfront as Virginia is Recommended for this…)

      Here are test page I created with videos embeded and descriptions.
      https://bimv.pl/test-video/

      Second issue is a quality…
      1. People say that it can’t keep the high quality throughout the whole video, it jumps betweend qualities, and it is generally hard to achieve automatically high quality.
      2. If I manually change the quality to the higher, the part that is loaded still stays in the lower quality, I have to click somwhere on the timeline outside loaded part, or have to refresh the whole page, I think that services like youtube work diffrent.

      • This topic was modified 3 years, 10 months ago by s3bubble.
    • #31926
      szmek9
      Participant

      About Ireland & Cloudfront, the video is playing now without any errors. It seem to be taking longer time for cloudfront to be enabled. Rest of the question still remain.

    • #31929
      s3bubble
      Keymaster

      Hi szmek9,

      Yes, that’s why we recommend N Virginia we have waited ages for Cloudfront to deployed in Ireland before to the point where it took so long we thought something had broken.

      There was a way to speed it up but i cant remember of the top of my head I will update this post when I remember.

      The player is initially set to auto and will change streams depending on connection speed when they select a high quality it should try to maintain that.

      We are going to run some checks we recently had a user request the ability to set a default quality and we are looking into this we do already have a force high quality options I think we need to revisit these.

      https://s3bubble.com/documentation/force-highest-quality/

      Best Regards

      Sam

Viewing 2 reply threads
  • The forum ‘General Questions & Bugs’ is closed to new topics and replies.